On a shoot, i realize that i can’t control the zoom level by remote.
I was able to switch to manual/remote, feel the motor or not, but nothing happen when i press zoom in or zoom out, both on the camera button or handle!
I had no idea if it was a sender (the camera) or receiver problem (the lens).

I bring back the camera to Sony and they said to me that the lens is dead, a new one is around rmb 7,000 (750 Euros)!
The repair guy did not touch the lens, just plug a new lens, test it, so affirm that i need a new one, without even opening mine!

I was not prepare to pay for a new one so decide to take back the lens at the office and open it to see how it is, anyway, the lens is dead to them.

Z7_Lens_open

I start opening the motor panel as it was for me a dead motor.
And i notice a slight lift under the motor where the switch is. (See the red arrow)
Z7_Lens_CloseUp
This switch is just glue to the camera body?! and the glue came off, so the switch was always on manual, even if i can move the mechanical position to auto with the motor.

I simply glue it back, wait 8 hours to have the glue dry and put all together….

And it’s working perfectly since then,

I can’t be more concern about the truth from the Sony Shanghai repair center,
As it’s glue, i can understand it’s happen quite often, my lens was 13 month old.

Z7_Lens_fixed

Thanks Sony Shanghai for your advice, never trust a repair guy … If you have dust in your screen, better do it yourself as well!
I also have the feeling that other camera lens control switch may have the same problem in other HVR sony line..